SECURITY UPDATE · ACTION REQUIRED
|
On October 21, 2026, PHP fixed CVE-2026-109618 and CVE-2026-109619. Both are rated CVSS v4.0 9.2 and may allow unauthenticated remote code execution. Affected environments include PHP-FPM, Apache mod_php, php-cgi, FrankenPHP and LiteSpeed. Risk is highest for mod_php. |
||||||||||||||||
Fixed PHP versionsPatches are available for PHP 7.4 – 8.5 only. Please update to one of the following patched releases:
|
||||||||||||||||
Update in aaPanel
Availability depends on your App Store. Users of PHP versions earlier than 7.4 should migrate to a supported release or confirm patches with their provider. |
||||||||||||||||
OpenLiteSpeed LSPHP update issueDue to a script compatibility issue with OpenLiteSpeed, the current script supports LSPHP installation but not upgrades. Please use apt/yum to update LSPHP for now. OpenLiteSpeed LSPHP update commands CentOS / AlmaLinux / Rocky
Debian / Ubuntu
|
||||||||||||||||
Temporary mitigationFor specific CVE-2026-109619 attack paths only. The PHP official advisory recommends the settings below to block confirmed session attack paths and, on PHP 8.5, the fatal error backtrace path. Open the affected PHP version’s Settings → Configuration file (php.ini) and set:
For PHP 8.5, also set:
Restart all affected PHP workers. Settings must apply before request parsing; do not rely on These measures do not fix both vulnerabilities or replace security updates. They only address specific paths for CVE-2026-109619. |
||||||||||||||||
Node.js security updatesNode.js fixed 10 vulnerabilities, including four high-severity issues. Update to 22.23.4, 24.22.1 or 26.12.1. Open Website → Node.js Project → Node version manager. Refresh the list and install a fixed release, then switch each project to it and restart. Installing a new version alone does not update existing projects. |
||||||||||||||||
Official advisories |